Red 1 - Internet not available

Identified

The issue has been identified as failing UPS devices attached to the core switch infrastructure. Internet services have been restored, but we will continue to experience outages during power fluctuations or brownouts until the UPS devices powering the core switches are replaced.
Posted Dec 18, 2025 - 14:54 PST

Investigating

Hello Everyone,

ITS is investigating internet issues in Red 1. We will follow up with more information once it becomes available.
Posted Dec 18, 2025 - 14:13 PST
This incident affects: Network Services (Redmond Production Network, Redmond Wireless Network, Redmond Config Network).