Salesforce Outage

Resolved

Salesforce has resolved the outage and services are back online.
Posted Sep 16, 2026 - 17:16 PDT

Monitoring

Hello Everyone,

The technology and ITS teams are tracking an outage of Salesforce services that is causing slowness and intermittent access issues to the Salesforce Platform. There is currently no ETA for resolution at this time.

Below is the URL to the Salesforce Incident for more details. ITS will continue to monitor the outage and send updates as needed.

Trust Status

Thanks,

ITS
Posted Sep 16, 2026 - 11:06 PDT
This incident affected: Line of Business Applications (Salesforce).